sho config
Using 677 out of 129016 bytes
!
version 10.2
!
hostname drouter
!
enable password drouter
!
!
interface Ethernet0
ip address 181.160.144.17 255.255.255.248
media-type 10BaseT
!
interface Ethernet1
no ip address
shutdown
!
interface Ethernet2
no ip address
shutdown
media-type 10BaseT
!
interface Ethernet3
no ip address
shutdown
!
interface Serial0
ip address 181.160.254.26 255.255.255.248
encapsulation ppp
clockrate 56000
dce-terminal-timing-enable
!
interface Serial1
no ip address
encapsulation ppp
shutdown
!
router ospf 1
network 181.160.254.0 0.0.0.255 area 0
network 181.160.144.0 0.0.15.255 area 4
network 181.160.160.0 0.0.15.255 area 4
network 181.160.176.0 0.0.15.255 area 4
area 4 range 181.160.144.0 255.255.240.0
area 4 range 181.160.160.0 255.255.240.0
area 4 range 181.160.176.0 255.255.240.0
!
!
line con 0
line aux 0
line vty 0 4
password drouter
login
!
end

drouter#sho ip ospf 1
 Routing Process "ospf 1" with ID 181.160.254.26
 Supports only single TOS(TOS0) routes
 It is an area border router
 Summary Link update interval is 0:30:00 and the update due in 0:04:01
 SPF schedule delay 5 secs, Hold time between two SPFs 10 secs
 Number of areas in this router is 2
    Area 4
	Number of interfaces in this area is 1
	Area has no authentication
	SPF algorithm executed 28 times
	Area ranges are
	Link State Update Interval is 0:30:00 and due in 0:22:14
	Link State Age Interval is 0:20:00 and due in 0:14:01
    Area BACKBONE(0)
	Number of interfaces in this area is 1
	Area has no authentication
	SPF algorithm executed 30 times
	Area ranges are
	Link State Update Interval is 0:30:00 and due in 0:29:18
	Link State Age Interval is 0:20:00 and due in 0:09:18